Du bist nicht angemeldet.

Werbeanzeige

ByteJunkie

Alter Hase

  • »ByteJunkie« ist der Autor dieses Themas

Beiträge: 834

Wohnort: Deutschland

Beruf: Softwareentwickler

  • Private Nachricht senden

1

11.10.2015, 11:32

Mono.posix fehlt unter windows

Hallo,

ich hab mich seit einem Jahrzehnt mal wieder ernsthaft mit Linux beschäftigt. Jetzt wollte ich ein einfaches mit Mono erstelltes GTK-Programm unter Windows laufen lassen.
Obwohl ich die GTK# unter Windows installiert habe fehlt wohl noch die Mono.Posix Komponente. Kann mir jemand sagen was ich verkehrt mache?
Oder sollte ich besser eine andere IDE unter Linux verwenden?
"Alles bleibt wie immer. :rolleyes: Wenn es nicht besser wird, wird es schlimmer!." :huh:

TrommlBomml

Community-Fossil

Beiträge: 2 143

Wohnort: Berlin

Beruf: Software-Entwickler

  • Private Nachricht senden

2

11.10.2015, 12:06

Posix hat nichts mit Windows zu tun. Du wirst die windows-assemblies benutzen müssen. Bei MonoGame ist das ähnlich, da verwendet man pro Plattform andere Assemblies für die nativen Abhängigkeiten. Da würde ich bei GTK# einfach mal lesen, da steht bestimmt was zu.

ByteJunkie

Alter Hase

  • »ByteJunkie« ist der Autor dieses Themas

Beiträge: 834

Wohnort: Deutschland

Beruf: Softwareentwickler

  • Private Nachricht senden

3

11.10.2015, 13:26

Das ist ja interessant ...

Wenn ich ein GTK-Programm unter Linux mit MonoDevelop erstelle und das erstellte Paket dann unter Windows laufen lasse kommt der Hinweis auf die fehlende Mono.posix.
Wenn ich das gleiche GTK-Programm, mit den gleichen Einstellungen, mit Xamarin unter Windows erstelle und das erstellte Paket dann unter Windows laufen lasse läuft alles einwandtfrei.

Hat jemand eine Ahnung wieso?

Ergänzung: Danke TrommlBomml
"Alles bleibt wie immer. :rolleyes: Wenn es nicht besser wird, wird es schlimmer!." :huh:

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »ByteJunkie« (11.10.2015, 21:03)


Werbeanzeige